Problem When Building Old OpenSSL Version on The New System


The old OpenSSL seems to have a problem when built using a newer system. I got this problem when compiling OpenSSL 1.1.0f on my Ubuntu 22.04.

derry@G14:~/openssl-1.1.0f$ ./config -d shared no-asm no-hw
Operating system: x86_64-whatever-linux2
"glob" is not exported by the File::Glob module
Can't continue after import errors at ./Configure line 17.
BEGIN failed--compilation aborted at ./Configure line 17.
"glob" is not exported by the File::Glob module
Can't continue after import errors at ./Configure line 17.
BEGIN failed--compilation aborted at ./Configure line 17.
This system (linux-x86_64) is not supported. See file INSTALL for details

For example in my case here the problem is in line 17 on Configure file and the line were like this:

# Old
## use if $^O ne "VMS", 'File::Glob' => qw/glob/;
# New
use if $^O ne "VMS", 'File::Glob' => qw/:glob/;

Some people tried changing the lines with qw/glob/ into qw/:glob/ and it works. But there was another one:


...
Configuring for linux-x86_64
Something wrong with this line:
Program fragment delivered error ``"glob" is not exported by the File::Glob module
at /mnt/c/Users/Derry/ws/openssl-1.1.0f/test/build.info at ./Configure line 1615.

So I did the same as before in the build.info file, and now the build works flawlessly. 🙂



Leave a Reply

Your email address will not be published.